<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">

<title>Mike Luckovich for Jun 10, 2022 - Mike Luckovich, Humor Times</title>
<meta name="description" content="-" />
<script src="/cdn-cgi/apps/head/iVEQWCsZSy5UpYlGKYudcFVGwJ8.js"></script><link rel="canonical" href="https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mike Luckovich for Jun 10, 2022 - Mike Luckovich, Humor Times" />
<meta property="og:description" content="-" />
<meta property="og:url" content="https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/" />
<meta property="og:site_name" content="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More" />
<meta property="article:publisher" content="https://www.facebook.com/HumorTimes" />
<meta property="article:published_time" content="2022-06-10T14:00:00+00:00" />
<meta property="og:image" content="https://cdn.creators.com/198/327439/327439_image.jpg" />
<meta property="og:image:secure_url" content="https://cdn.creators.com/198/327439/327439_image.jpg" />
<meta property="og:image:type" content="2" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="523" />
<meta name="twitter:image" content="https://cdn.creators.com/198/327439/327439_image.jpg" />
<meta name="twitter:image:alt" content="Humor Times image" />
<meta property="og:image" content="https://cdn.creators.com/198/327439/327439_image.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@humortimes" />
<meta name="twitter:site" content="@humortimes" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Mike Luckovich" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.humortimes.com/#website","url":"https://www.humortimes.com/","name":"Humor Times: Political Satire, Cartoons, Videos, Satirical News and More","description":"“World‘s Funniest News Source”","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.humortimes.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/#primaryimage","url":"https://cdn.creators.com/198/327439/327439_image.jpg","contentUrl":"https://cdn.creators.com/198/327439/327439_image.jpg"},{"@type":"WebPage","@id":"https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/#webpage","url":"https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/","name":"Mike Luckovich for Jun 10, 2022 - Mike Luckovich, Humor Times","isPartOf":{"@id":"https://www.humortimes.com/#website"},"primaryImageOfPage":{"@id":"https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/#primaryimage"},"datePublished":"2022-06-10T14:00:00+00:00","dateModified":"2022-06-10T14:00:00+00:00","author":{"@id":"https://www.humortimes.com/#/schema/person/fab97cad39982e81be7204a5f5fbb7d7"},"description":"-","breadcrumb":{"@id":"https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/"]}]},{"@type":"BreadcrumbList","@id":"https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.humortimes.com/"},{"@type":"ListItem","position":2,"name":"Cartoons","item":"https://www.humortimes.com/topics/cartoons/"},{"@type":"ListItem","position":3,"name":"Creators","item":"https://www.humortimes.com/topics/cartoons/creators/"},{"@type":"ListItem","position":4,"name":"Luckovich","item":"https://www.humortimes.com/topics/cartoons/creators/luckovich/"},{"@type":"ListItem","position":5,"name":"Mike Luckovich for Jun 10, 2022"}]},{"@type":"Person","@id":"https://www.humortimes.com/#/schema/person/fab97cad39982e81be7204a5f5fbb7d7","name":"Mike Luckovich","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.humortimes.com/#/schema/person/image/","url":"https://www.humortimes.com/wp-content/uploads/2021/01/mike-luckovich_thumb-200x200.jpg","contentUrl":"https://www.humortimes.com/wp-content/uploads/2021/01/mike-luckovich_thumb-200x200.jpg","caption":"Mike Luckovich"},"description":"Mike Luckovich of the Atlanta Constitution received two amazing honors in 2006, winning both a Pulitzer Prize and the Reuben award for Outstanding Cartoonist of the Year. This was the second Pulitzer for Luckovich; his first was awarded in 1995. He had previously received the Reuben award for Editorial Cartooning in 2001, but this was his first time to be named the overall outstanding cartoonist by a group of his peers. The Reuben awards are distributed each year by the National Cartoonists Society and are considered professional cartooning's highest honor. Impressive as these achievements are, they are only the latest in a long line of awards for Luckovich. He was a runner-up for the Pulitzer in 1987 before garnering the 1995 win.  In 1989, he won the Overseas Press Club's award for the \"Best Cartoons on Foreign Affairs for 1989,\" and in 1991, he was awarded the National Headliners award for editorial cartoonists. In 1994, a Luckovich cartoon was selected by voters in a Newsweek magazine poll as one of the four best editorial cartoons of the year. After freelancing and selling life insurance to make ends meet following his graduation from the University of Washington in 1982, Luckovich landed his first cartooning job at the Greenville News in South Carolina. After nine months at the News, Luckovich was hired by The Times-Picayune in New Orleans, where he stayed for four years before moving on to Atlanta. Luckovich's cartoons, syndicated nationally by Creators Syndicate, appear in more than 350 daily publications, including The Washington Post,The San Diego Union-Tribune, The Denver Post, Newsday, New York Post, The Cleveland Plain-Dealer, The Dallas Morning News, the Boston Globe, the Seattle Times, the Los Angeles Times, the Chicago Tribune, the Nashville Tennessean and the Houston Chronicle, and are reprinted regularly in Time, Newsweek and the New York Times. Luckovich and his wife, Margo, have four children. His hobbies include exercising and collecting unique ties.","sameAs":["http://www.creators.com/read/lk"],"url":"https://www.humortimes.com/author/mikeluckovich/"}]}</script>

<link rel='dns-prefetch' href='//static.addtoany.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More &raquo; Feed" href="https://www.humortimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More &raquo; Comments Feed" href="https://www.humortimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More &raquo; Mike Luckovich for Jun 10, 2022 Comments Feed" href="https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/feed/" />
<script>
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.humortimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='SFMCss-css' href='https://www.humortimes.com/wp-content/plugins/feedburner-alternative-and-rss-redirect/css/sfm_style.css?ver=6.0' media='all' />
<link rel='stylesheet' id='SFMCSS-css' href='https://www.humortimes.com/wp-content/plugins/feedburner-alternative-and-rss-redirect/css/sfm_widgetStyle.css?ver=6.0' media='all' />
<link rel='stylesheet' id='tubepress-theme-0-css' href='https://www.humortimes.com/wp-content/plugins/tubepress_pro_5_1_8/web/themes/default/css/tubepress.css?ver=5.1.8' media='all' />
<link rel='stylesheet' id='wpapp-styles-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-easy-paypal-payment-or-donation-accept-plugin/wpapp-styles.css?ver=6.0' media='all' />
<link rel='stylesheet' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.humortimes.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='responsive-lightbox-swipebox-css' href='https://www.humortimes.com/wp-content/plugins/responsive-lightbox/assets/swipebox/swipebox.min.css?ver=2.3.5' media='all' />
<link rel='stylesheet' id='wordpress-file-upload-style-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/css/wordpress_file_upload_style.css?ver=6.0' media='all' />
<link rel='stylesheet' id='wordpress-file-upload-style-safe-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/css/wordpress_file_upload_style_safe.css?ver=6.0' media='all' />
<link rel='stylesheet' id='wordpress-file-upload-adminbar-style-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/css/wordpress_file_upload_adminbarstyle.css?ver=6.0' media='all' />
<link rel='stylesheet' id='jquery-ui-css-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/vendor/jquery/jquery-ui.min.css?ver=6.0' media='all' />
<link rel='stylesheet' id='jquery-ui-timepicker-addon-css-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/vendor/jquery/jquery-ui-timepicker-addon.min.css?ver=6.0' media='all' />
<link rel='stylesheet' id='ppress-frontend-css' href='https://www.humortimes.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.13' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css' href='https://www.humortimes.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.13' media='all' />
<link rel='stylesheet' id='ppress-select2-css' href='https://www.humortimes.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=6.0' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://www.humortimes.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' media='all' />
<link rel='stylesheet' id='generate-style-css' href='https://www.humortimes.com/wp-content/themes/generatepress/assets/css/all.min.css?ver=3.1.3' media='all' />
<style id='generate-style-inline-css'>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</style>
<link rel='stylesheet' id='generate-font-icons-css' href='https://www.humortimes.com/wp-content/themes/generatepress/assets/css/components/font-icons.min.css?ver=3.1.3' media='all' />
<link rel='stylesheet' id='generate-child-css' href='https://www.humortimes.com/wp-content/themes/generatepress-child/style.css?ver=1648845799' media='all' />
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css' href='https://www.humortimes.com/wp-content/plugins/recent-posts-widget-thumbs-mine/public.css?ver=7.0.1' media='all' />
<link rel='stylesheet' id='newsletter-css' href='https://www.humortimes.com/wp-content/plugins/newsletter/style.css?ver=7.4.6' media='all' />
<style id='newsletter-inline-css'>
/* Subscription form label - was white, couldn't read */
.tnp-field label { color: #23282D !important; }
.tnp-subscription input.tnp-submit {
    background-color: #85B1DD !important;
    color: #23282D !important;
}
img { border-style: none !important; }
.banner { margin: 10px 0; }

#tnp-leads-topbar .tnp-subscription-minimal input.tnp-submit {
  max-width: none !important;
}
</style>
<link rel='stylesheet' id='newsletter-leads-css' href='https://www.humortimes.com/wp-content/plugins/newsletter-leads/css/leads.css?ver=1.2.8' media='all' />
<style id='newsletter-leads-inline-css'>
            #tnp-leads-topbar {
                            top: -200px;
                transition: top 1s;
                        }
            #tnp-leads-topbar.tnp-leads-topbar-show {
                                                top:0px;
                                        }
            #tnp-leads-topbar {
            background-color: #55ab68 !important;
            }
            #tnp-leads-topbar .tnp-subscription-minimal input.tnp-email {
            width: auto!important;
            }
            #tnp-leads-topbar .tnp-subscription-minimal input.tnp-submit {
            background-color: #5197d5 !important;
            width: auto!important;
            }
            
</style>
<link rel='stylesheet' id='addtoany-css' href='https://www.humortimes.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.16' media='all' />
<script src='https://www.humortimes.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/tubepress_pro_5_1_8/web/js/tubepress.js?ver=5.1.8' id='tubepress-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/tubepress_pro_5_1_8/web/js/wordpress-ajax.js?ver=5.1.8' id='tubepress_ajax-js'></script>
<script id='addtoany-core-js-before'>
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.templates.twitter = "${title} ${link} via @humortimes";
a2a_config.thanks = {
    postShare: true,
    ad: false
};
// add share buttons to images
a2a_config.overlays.push({
    services: [ 'pinterest', 'facebook', 'twitter', 'tumblr'],
});
</script>
<script defer async src='https://static.addtoany.com/menu/page.js' id='addtoany-core-js'></script>
<script defer async src='https://www.humortimes.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-jquery-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=6.0' id='responsive-lightbox-infinite-scroll-js'></script>
<!--[if lt IE 8]>
<script defer src='https://www.humortimes.com/wp-includes/js/json2.min.js?ver=2015-05-03' id='json2-js'></script>
<![endif]-->
<script defer src='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/js/wordpress_file_upload_functions.js?ver=6.0' id='wordpress_file_upload_script-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.13.1' id='jquery-ui-datepicker-js'></script>
<script id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/wordpress-file-upload-pro/vendor/jquery/jquery-ui-timepicker-addon.min.js?ver=6.0' id='jquery-ui-timepicker-addon-js-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=6.0' id='ppress-flatpickr-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=6.0' id='ppress-select2-js'></script>
<script id='wpp-json' type="application/json">
{"sampling_active":1,"sampling_rate":10,"ajax_url":"https:\/\/www.humortimes.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.humortimes.com\/wp-json\/wordpress-popular-posts","ID":100669,"token":"cb9edeb088","lang":0,"debug":0}
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://www.humortimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.humortimes.com/wp-json/wp/v2/posts/100669" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.humortimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.humortimes.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0" />
<link rel='shortlink' href='https://www.humortimes.com/?p=100669' />
<link rel="alternate" type="application/json+oembed" href="https://www.humortimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.humortimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 1px 1px 1px; }
	.g-2 { width:auto; }
	.b-2 { margin:0px; }
	.g-3 { width:auto; }
	.b-3 { margin:0px; }
	.g-4 { margin:0px 1px 1px 1px; }
	.g-5 { min-width:1px; max-width:162px; }
	.b-5 { margin:0px 1px 1px 1px; }
	.g-6 { width:auto; }
	.b-6 { margin:0px; }
	.g-7 { margin:0px 1px 1px 1px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-8 { margin:0px 1px 1px 1px; }
	.g-10 { margin:0px;  width:100%; max-width:468px; height:100%; max-height:135px; }
	.g-12 { min-width:0px; max-width:236px; }
	.b-12 { margin:0px 0px 0px 0px; }
	.g-13 { margin:0px;  width:auto; height:auto; }
	.g-14 { width:auto; }
	.b-14 { margin:0px; }
	.g-15 { min-width:10px; max-width:320px; }
	.b-15 { margin:10px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<meta name="follow.it-verification-code-dnluSXJaUStRRFVEejFIakd2TFRJYTJVSHd5TElaNis2Unp0RlpuWFYzNjJQQURJNjFnRm5jNzcvdCtiN0UrclU5S1VEZytVYTU1MzJnQWZMeG1tQldMcGxqS1VRc3dCcS9UTk5rNnpnS05mYStvd2tpdVRtdkljSWRxQXAyT1R8RTgwNFQwS3pXeVptNUVKQ2xlVXFWZkJKaVMxYXdvSmpWSnJoYjBwemR1az0=" content="7cRkY38sSvMkXyJzyaTN" /> <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '8f2eb008ab'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.humortimes.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script>


<link rel='stylesheet' id='ABHfrontend.min.css-css' href='https://www.humortimes.com/wp-content/plugins/starbox/themes/fancy/css/frontend.min.css?ver=3.4.4' media='all' />
<script defer src='https://www.humortimes.com/wp-content/plugins/starbox/themes/fancy/js/frontend.min.js?ver=3.4.4' id='ABHfrontend.min.js-js'></script>
<link rel='stylesheet' id='ABHhidedefault.min.css-css' href='https://www.humortimes.com/wp-content/plugins/starbox/themes/admin/css/hidedefault.min.css?ver=3.4.4' media='all' />
<script type="text/javascript">var TubePressJsConfig = {"urls":{"base":"\/wp-content\/plugins\/tubepress_pro_5_1_8","usr":"\/wp-content\/tubepress-content","ajax":"\/wp-admin\/admin-ajax.php"}};</script> <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>

<script>var WP_Statistics_http = new XMLHttpRequest();WP_Statistics_http.open('GET', 'https://www.humortimes.com/wp-json/wp-statistics/v2/hit?_=1654885295&_wpnonce=cb9edeb088&wp_statistics_hit_rest=yes&browser=Common Crawl Bot&platform=Unknown&version=3.0&referred=https%3A%2F%2Fwww.humortimes.com&ip=35.173.238.138&exclusion_match=yes&exclusion_reason=CrawlerDetect&ua=CCBot%2F3.0+%28https%3A%2F%2Fcommoncrawl.org%2Ffaq%2F%3B+info%40commoncrawl.org%29&track_all=1&timestamp=1654860095&current_page_type=post&current_page_id=100669&search_query&page_uri=/100669/327439-mike-luckovich-for-jun-10-2022/&user_id=0', true);WP_Statistics_http.setRequestHeader("Content-Type", "application/json;charset=UTF-8");WP_Statistics_http.send(null);</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1257467-1"></script>
<script async>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-1257467-1');
</script>

<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.humortimes.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '5270689c-5f96-4d8a-af0e-64b46df94a8d';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.humortimes.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = "You may unsubscribe by clicking on gear icon.";
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = "Unsubscribe by clicking on gear icon.";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<noscript><style>.lazyload[data-src]{display:none !important;}</style></noscript><style>.lazyload{background-image:none !important;}.lazyload:before{background-image:none !important;}</style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.humortimes.com/wp-content/uploads/2017/06/cropped-HT-fav-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.humortimes.com/wp-content/uploads/2017/06/cropped-HT-fav-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.humortimes.com/wp-content/uploads/2017/06/cropped-HT-fav-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.humortimes.com/wp-content/uploads/2017/06/cropped-HT-fav-270x270.png" />
</head>
<body itemtype='https://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-100669 single-format-standard wp-custom-logo wp-embed-responsive right-sidebar nav-below-header separate-containers fluid-header active-footer-widgets-4 nav-search-enabled nav-aligned-center header-aligned-center dropdown-hover">
<script data-cfasync="false">var ewww_webp_supported=false;</script>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <div class="top-bar top-bar-align-center">
<div class="inside-top-bar grid-container grid-parent">
<aside id="adrotate_widgets-87" class="widget inner-padding adrotate_widgets"></aside> </div>
</div>
<header class="site-header" id="masthead" aria-label="Site" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header grid-container grid-parent">
<div class="header-widget">
<aside id="adrotate_widgets-85" class="widget inner-padding adrotate_widgets"><div class="g g-10"><div class="g-dyn a-80 c-1"><a class="gofollow" data-track="ODAsMTAsMSw2MA==" href="https://subs.humortimes.com/subs-ht-trial-free.php?origpg=main-site" rel="nofollow"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAdQAAACCAQAAAADX/ASfAAAAAnRSTlMAAHaTzTgAAAAeSURBVFjD7cExAQAAAMKg9U9tB2+gAAAAAAAAAOA3HngAARco3ZkAAAAASUVORK5CYII=" alt="Humor Times free trial" data-src="https://www.humortimes.com/wp-content/banners/button-468wx130-free-trial.gif" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/banners/button-468wx130-free-trial.gif" alt="Humor Times free trial" data-eio="l" /></noscript></a></div></div></aside> </div>
<div class="site-logo">
<a href="https://www.humortimes.com/" title="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More" rel="home">
<img class="header-image is-logo-image lazyload" alt="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAXcAAAB3AQAAAADQzD3nAAAAAnRSTlMAAHaTzTgAAAAcSURBVFjD7cGBAAAAAMOg+VMf4QJVAQAAAADANxZQAAHxeGeQAAAAAElFTkSuQmCC" title="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More" data-src="https://www.humortimes.com/wp-content/uploads/2017/09/HT-logo.png" decoding="async" /><noscript><img  class="header-image is-logo-image" alt="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More" src="https://www.humortimes.com/wp-content/uploads/2017/09/HT-logo.png" title="Humor Times: Political Satire, Cartoons, Videos, Satirical News and More" data-eio="l" /></noscript>
</a>
</div><div class="site-branding">
<p class="site-description" itemprop="description">
“World‘s Funniest News Source”
</p>
</div> </div>
</header>
<nav class="main-navigation sub-menu-right" id="site-navigation" aria-label="Primary" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation grid-container grid-parent">
<form method="get" class="search-form navigation-search" action="https://www.humortimes.com/">
<input type="search" class="search-field" value="" name="s" title="Search" />
</form> <div class="mobile-bar-items">
<span class="search-item">
<a aria-label="Open Search Bar" href="#">
</a>
</span>
</div>
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="mobile-menu">Menu</span> </button>
<div id="primary-menu" class="main-nav"><ul id="menu-main" class=" menu sf-menu"><li id="menu-item-818" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-818"><a href="https://www.humortimes.com/">Home</a></li>
<li id="menu-item-76254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-76254"><a>Cartoons<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-91079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-91079"><a href="https://www.humortimes.com/topics/cartoons/political-toons/">Political Cartoons<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-91597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91597"><a href="https://www.humortimes.com/editorial-cartoons-daily/">Editorial Cartoons Daily Update</a></li>
<li id="menu-item-79194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79194"><a href="https://www.humortimes.com/more/about-humor-times/1847-humor-times-magazine-covers-gallery/">Humor Times Covers Gallery</a></li>
<li id="menu-item-6579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6579"><a href="/?p=6576">Rob Rogers</a></li>
<li id="menu-item-2449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2449"><a href="/?p=2442">Tom the Dancing Bug</a></li>
<li id="menu-item-83661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83661"><a href="https://www.humortimes.com/cartoons/al-goodwyn/">﻿﻿﻿Al ﻿Goodwyn</a></li>
<li id="menu-item-61484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61484"><a href="https://www.humortimes.com/cartoons/chuck-legge-cartoons/">Chuck Legge</a></li>
<li id="menu-item-86435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86435"><a href="https://www.humortimes.com/cartoons/dan-alba-cartoons/">Dan Alba</a></li>
<li id="menu-item-88127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88127"><a href="https://www.humortimes.com/cartoons/dc-crap/">DC C.R.A.P. Meme Gallery</a></li>
<li id="menu-item-67792" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67792"><a href="https://www.humortimes.com/cartoons/iphoneys/">iPhoneys</a></li>
<li id="menu-item-68190" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68190"><a href="https://www.humortimes.com/cartoons/joe-heller-editorial-cartoons/">Joe Heller</a></li>
<li id="menu-item-25210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25210"><a href="/?p=25207">Michael Egan</a></li>
<li id="menu-item-3533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3533"><a href="/?p=2635">Mr. Brunelle Explains It All</a></li>
<li id="menu-item-65448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65448"><a href="https://www.humortimes.com/cartoons/polichics/">Polichics</a></li>
<li id="menu-item-86960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86960"><a href="https://www.humortimes.com/cartoons/joshua-zepess-polimericks/">Polimerick Memes by Josh Zepess</a></li>
<li id="menu-item-6582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6582"><a href="/?p=6581">Tom Toles (archives)</a></li>
</ul>
</li>
<li id="menu-item-23432" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-23432"><a href="https://www.humortimes.com/cartoons/">Panel Cartoons<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-11169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11169"><a href="/?p=1661">Bizarro</a></li>
<li id="menu-item-79500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79500"><a href="/?p=79475">Alice</a></li>
<li id="menu-item-31921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31921"><a href="/?p=31911">Avant Gauche</a></li>
<li id="menu-item-13401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13401"><a href="/?p=13396">Berserk Alert!</a></li>
<li id="menu-item-3514" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3514"><a href="/?p=3511">Big Monkey Comic</a></li>
<li id="menu-item-1560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1560"><a href="/?p=1556">Cartertoons</a></li>
<li id="menu-item-1602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1602"><a href="/?p=1569">Cornered</a></li>
<li id="menu-item-34326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34326"><a href="/?p=34318">The Daily Toon</a></li>
<li id="menu-item-38360" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38360"><a href="https://www.humortimes.com/dan-rosandich-cartoons/">Dan Rosandich</a></li>
<li id="menu-item-16985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16985"><a href="/?p=16977">Dr Doodle</a></li>
<li id="menu-item-1603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1603"><a href="/?p=1565">Harley Schwadron</a></li>
<li id="menu-item-82160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-82160"><a href="https://www.humortimes.com/cartoons/john-anglin-cartoons/">John Anglin</a></li>
<li id="menu-item-69813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69813"><a href="https://www.humortimes.com/cartoons/john-stinger-cartoons/">John Stinger</a></li>
<li id="menu-item-60553" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60553"><a href="https://www.humortimes.com/cartoons/odds/">THE ODDs</a></li>
<li id="menu-item-18413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18413"><a href="https://www.humortimes.com/18297/plan-b-cartoons/">Plan &#8216;B&#8217;</a></li>
<li id="menu-item-94949" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94949"><a href="https://www.humortimes.com/cartoons/r-g-karkovsky-cartoons/">R. G. Karkovsky Cartoons</a></li>
<li id="menu-item-1601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1601"><a href="/?p=1571">Surveillance Caricatures</a></li>
<li id="menu-item-57322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57322"><a href="https://www.humortimes.com/cartoons/weiss-cracks/">Weiss Cracks</a></li>
<li id="menu-item-93095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93095"><a href="https://www.humortimes.com/cartoons/yin-yangster/">Yin + Yangster</a></li>
</ul>
</li>
<li id="menu-item-21138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21138"><a href="https://www.humortimes.com/cartoon-caption-contest/">Cartoon Caption Contest</a></li>
<li id="menu-item-79675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79675"><a href="https://www.humortimes.com/topics/cartoons/funnies-farrago/">Funnies Farrago</a></li>
<li id="menu-item-15616" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15616"><a href="https://www.humortimes.com/more/about-humor-times/1847-humor-times-magazine-covers-gallery/">Humor Times Covers Gallery</a></li>
<li id="menu-item-24505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24505"><a href="https://www.humortimes.com/topics/cartoons/insight-on-cartoonists/">Insight on Cartoonists</a></li>
<li id="menu-item-1117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1117"><a href="https://www.humortimes.com/amateur-cartoons/">Reader-Created Cartoons</a></li>
<li id="menu-item-61503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-61503"><a href="https://www.humortimes.com/cartoons/cartoon-ads/">Cartoon Ads<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-61504" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61504"><a href="https://www.humortimes.com/cartoons/cartoon-ads/pot-medicine-woman/">Dr Quince, Pot Medicine Woman</a></li>
</ul>
</li>
<li id="menu-item-69056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-69056"><a href="https://www.humortimes.com/humor-times-app-news-cartoons/">Our Free App: &#8216;The News in Cartoons!&#8217;<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-63914" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-63914"><a href="https://www.humortimes.com/wp-content/mu-plugins/website/humortimes/index.html">&#8216;News in Cartoons&#8217; App Archives<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-21034" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21034"><a href="https://www.humortimes.com/topics/cartoons/news-in-cartoons/">Older &#8216;News in Cartoons&#8217;</a></li>
</ul>
</li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-76253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-76253"><a>Videos<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-17963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17963"><a href="https://www.humortimes.com/videos/1802-funny-videos/">Funny Videos</a></li>
<li id="menu-item-17957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17957"><a href="https://www.humortimes.com/videos/1796-political-humor-videos/">Political Humor Videos</a></li>
<li id="menu-item-6604" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6604"><a href="https://www.humortimes.com/videos/funny-videos-wall-of-fame/">Funny Videos Wall of Fame</a></li>
<li id="menu-item-1809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1809"><a href="https://www.humortimes.com/videos/1805-user-submitted-videos/">User-Submitted Funny Videos</a></li>
</ul>
</li>
<li id="menu-item-802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-802"><a href="https://www.humortimes.com/topics/humor-columns/">Humor Columns<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-30136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30136"><a href="https://www.humortimes.com/topics/humor-columns/ripping-the-headlines-today/">Ripping the Headlines Today</a></li>
<li id="menu-item-64508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64508"><a href="https://www.humortimes.com/topics/humor-columns/jerry-duncan-show/">Jerry Duncan Radio Talk Show!</a></li>
<li id="menu-item-825" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-825"><a href="https://www.humortimes.com/topics/humor-columns/jim-hightower-column/">Jim Hightower</a></li>
<li id="menu-item-87133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87133"><a href="https://www.humortimes.com/author/rlombard/">Ralph Lombard</a></li>
<li id="menu-item-3891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3891"><a href="https://www.humortimes.com/topics/humor-columns/roz-warren-column/">Roz Warren</a></li>
<li id="menu-item-23465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23465"><a href="https://www.humortimes.com/topics/humor-columns/howard-zaharoff-column/">Howard Zaharoff</a></li>
<li id="menu-item-64507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64507"><a href="https://www.humortimes.com/topics/humor-columns/horoscope/">Funny Horoscope</a></li>
<li id="menu-item-808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-808"><a href="https://www.humortimes.com/topics/humor-columns/will-durst-column/">Will Durst</a></li>
</ul>
</li>
<li id="menu-item-1681" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1681"><a href="https://www.humortimes.com/topics/faux-news/">Faux News</a></li>
<li id="menu-item-10104" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10104"><a href="https://www.humortimes.com/topics/reviews/">Reviews<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-807"><a href="https://www.humortimes.com/topics/reviews/movie-reviews/">Movie Reviews by Gary Chew</a></li>
<li id="menu-item-10105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10105"><a href="https://www.humortimes.com/topics/reviews/book-reviews/">Book Reviews</a></li>
</ul>
</li>
<li id="menu-item-1390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1390"><a href="https://www.humortimes.com/topics/blogs/">Blogs<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-822"><a href="https://www.humortimes.com/topics/blogs/editors-rant/">Editor&#8217;s Rant</a></li>
<li id="menu-item-23669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23669"><a href="https://www.humortimes.com/topics/blogs/roger-freed-blog/">Roger Freed&#8217;s Blog</a></li>
<li id="menu-item-23668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23668"><a href="https://www.humortimes.com/topics/blogs/p-beckert-column/">P. Beckert&#8217;s Column</a></li>
<li id="menu-item-3957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3957"><a href="https://www.humortimes.com/topics/blogs/seen-and-heard/">Seen &amp; Heard on the Web</a></li>
<li id="menu-item-23667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23667"><a href="https://www.humortimes.com/topics/blogs/news/">News</a></li>
<li id="menu-item-24504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24504"><a href="https://www.humortimes.com/topics/cartoons/insight-on-cartoonists/">Insight on Cartoonists</a></li>
</ul>
</li>
<li id="menu-item-827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-827"><a href="https://www.humortimes.com/topics/userfun/">User Fun<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-1116" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1116"><a href="https://www.humortimes.com/amateur-cartoons/">Reader-Created Cartoons</a></li>
<li id="menu-item-1812" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1812"><a href="https://www.humortimes.com/videos/1805-user-submitted-videos/">User-Submitted Funny Videos</a></li>
<li id="menu-item-21139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21139"><a href="https://www.humortimes.com/cartoon-caption-contest/">Cartoon Caption Contest</a></li>
<li id="menu-item-69058" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69058"><a href="https://www.humortimes.com/humor-times-app-news-cartoons/">Our Free App: &#8216;The News in Cartoons!&#8217;</a></li>
</ul>
</li>
<li id="menu-item-62844" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-62844"><a href="https://subs.humortimes.com/">Subscribe<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-59652" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59652"><a href="https://subs.humortimes.com/login.htm">Current Subscriber Login</a></li>
<li id="menu-item-33644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33644"><a href="https://www.humortimes.com/read-recent-humor-times-back-issue/">Read a Recent Issue Online</a></li>
<li id="menu-item-63106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63106"><a href="https://www.humortimes.com/donate-cause-political-humor/">Donate to the Cause of Political Humor!</a></li>
</ul>
</li>
<li id="menu-item-76255" class="open-left menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-76255"><a>More<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-63105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63105"><a href="https://www.humortimes.com/donate-cause-political-humor/">Donate to the Cause of Political Humor!</a></li>
<li id="menu-item-810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-810"><a href="https://www.humortimes.com/more/free-newsletter/">Free Newsletter!</a></li>
<li id="menu-item-91598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91598"><a href="https://www.humortimes.com/more/letters-to-editor/">Letters to the Editor</a></li>
<li id="menu-item-8828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8828"><a href="https://www.humortimes.com/more/about-humor-times/advertising-info-request-form/">Advertise in the Humor Times</a></li>
<li id="menu-item-811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-811"><a href="https://www.humortimes.com/more/about-humor-times/teachers-aide-the-humor-times/">HT as Teacher&#8217;s Aide</a></li>
<li id="menu-item-1850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1850"><a href="https://www.humortimes.com/more/about-humor-times/1847-humor-times-magazine-covers-gallery/">HT Magazine Covers Gallery</a></li>
<li id="menu-item-814" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-814"><a href="https://www.humortimes.com/links/">Links<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-813"><a href="https://www.humortimes.com/links/funny-links/">Funny Links</a></li>
<li id="menu-item-1065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1065"><a href="https://www.humortimes.com/links/political-links/">Political Links</a></li>
<li id="menu-item-1218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1218"><a href="https://www.humortimes.com/links/other-links/">Other Links</a></li>
<li id="menu-item-23156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23156"><a href="https://www.humortimes.com/links/link-humor-times/">Link to the Humor Times!</a></li>
</ul>
</li>
<li id="menu-item-8815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-8815"><a href="https://www.humortimes.com/more/about-humor-times/">About Humor Times<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-10146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10146"><a href="https://subs.humortimes.com/">Subscribe to HT magazine!</a></li>
<li id="menu-item-816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-816"><a href="https://www.humortimes.com/more/about-humor-times/testimonials/">HT magazine testimonials</a></li>
<li id="menu-item-21431" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21431"><a href="https://www.humortimes.com/more/about-humor-times/humor-times-authors/">List of Writers &#038; Cartoonists</a></li>
<li id="menu-item-8827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8827"><a href="https://www.humortimes.com/more/about-humor-times/submissions-guidelines/">Submissions Guidelines</a></li>
<li id="menu-item-23157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23157"><a href="https://www.humortimes.com/links/link-humor-times/">Link to the Humor Times!</a></li>
</ul>
</li>
<li id="menu-item-817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-817"><a href="https://www.humortimes.com/more/contact-us/">Contact us</a></li>
</ul>
</li>
<li class="search-item menu-item-align-right"><a aria-label="Open Search Bar" href="#"></a></li></ul></div> </div>
</nav>
<div id="page" class="hfeed site grid-container container grid-parent">
<div id="content" class="site-content">
<div class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75" id="primary">
<main class="site-main" id="main">
<article id="post-100669" class="post-100669 post type-post status-publish format-standard hentry category-creators category-luckovich tag-cartoonists tag-cartoons tag-editorial-cartoons tag-mike-luckovich tag-news-2 tag-political-cartoonists tag-political-cartoons tag-political-satire tag-satire" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<header class="entry-header">
<h1 class="entry-title" itemprop="headline">Mike Luckovich for Jun 10, 2022</h1> <div class="entry-meta">
<span class="byline"><span class="author vcard" itemtype="https://schema.org/Person" itemscope="itemscope" itemprop="author">By <a class="url fn n" href="https://www.humortimes.com/author/mikeluckovich/" title="View all posts by Mike Luckovich" rel="author" itemprop="url"><span class="author-name" itemprop="name">Mike Luckovich</span></a></span></span><span class="posted-on">, <a href="https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/" title="7:00 AM" rel="bookmark"><time class="entry-date published" datetime="2022-06-10T07:00:00-07:00" itemprop="datePublished">June 10, 2022</time></a></span> </div>
</header>
<div class="entry-content" itemprop="text">
<p><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Mike Luckovich for Jun 10, 2022" data-src="https://cdn.creators.com/198/327439/327439_image.jpg" decoding="async" class="lazyload" /><noscript><img src="https://cdn.creators.com/198/327439/327439_image.jpg" alt="Mike Luckovich for Jun 10, 2022" data-eio="l" /></noscript></p>
<div class="abh_box abh_box_down abh_box_fancy"><ul class="abh_tabs"> <li class="abh_about abh_active"><a href="#abh_about">Author</a></li> <li class="abh_posts"><a href="#abh_posts">Recent Posts</a></li></ul><div class="abh_tab_content"><section class="vcard author abh_about_tab abh_tab" itemscope itemprop="author" itemtype="http://schema.org/Person" style="display:block"><div class="abh_image" itemscope itemtype="http://schema.org/ImageObject"><a href="http://www.creators.com/read/lk" class="url" target="_blank" title="Mike Luckovich" rel="nofollow"> <img data-del="avatar" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAMgAAADIAQAAAACFI5MzAAAAAnRSTlMAAHaTzTgAAAAcSURBVFjD7cGBAAAAAMOg+VNf4QBVAQAAAAB8BhRQAAEAnyMVAAAAAElFTkSuQmCC" class="avatar pp-user-avatar avatar-250 photo  lazyload" height='250' width='250' data-src="https://www.humortimes.com/wp-content/uploads/2021/01/mike-luckovich_thumb.jpg" decoding="async" /><noscript><img data-del="avatar" src='https://www.humortimes.com/wp-content/uploads/2021/01/mike-luckovich_thumb.jpg' class='avatar pp-user-avatar avatar-250 photo ' height='250' width='250' data-eio="l" /></noscript></a > </div><div class="abh_social"> </div><div class="abh_text"><div class="abh_name fn name" itemprop="name"><a href="http://www.creators.com/read/lk" class="url" target="_blank" rel="nofollow">Mike Luckovich</a></div><div class="abh_job"></div><div class="description note abh_description" itemprop="description">Mike Luckovich of the Atlanta Constitution received two amazing honors in 2006, winning both a Pulitzer Prize and the Reuben award for Outstanding Cartoonist of the Year. This was the second Pulitzer for Luckovich; his first was awarded in 1995. He had previously received the Reuben award for Editorial Cartooning in 2001, but this was his first time to be named the overall outstanding cartoonist by a group of his peers. The Reuben awards are distributed each year by the National Cartoonists Society and are considered professional cartooning's highest honor. <br /><br /> Impressive as these achievements are, they are only the latest in a long line of awards for Luckovich. He was a runner-up for the Pulitzer in 1987 before garnering the 1995 win.  In 1989, he won the Overseas Press Club's award for the "Best Cartoons on Foreign Affairs for 1989," and in 1991, he was awarded the National Headliners award for editorial cartoonists. In 1994, a Luckovich cartoon was selected by voters in a Newsweek magazine poll as one of the four best editorial cartoons of the year.<br /><br />After freelancing and selling life insurance to make ends meet following his graduation from the University of Washington in 1982, Luckovich landed his first cartooning job at the Greenville News in South Carolina. After nine months at the News, Luckovich was hired by The Times-Picayune in New Orleans, where he stayed for four years before moving on to Atlanta.<br /><br />Luckovich's cartoons, syndicated nationally by Creators Syndicate, appear in more than 350 daily publications, including The Washington Post,The San Diego Union-Tribune, The Denver Post, Newsday, New York Post, The Cleveland Plain-Dealer, The Dallas Morning News, the Boston Globe, the Seattle Times, the Los Angeles Times, the Chicago Tribune, the Nashville Tennessean and the Houston Chronicle, and are reprinted regularly in Time, Newsweek and the New York Times.<br /><br />Luckovich and his wife, Margo, have four children. His hobbies include exercising and collecting unique ties.</div></div> </section><section class="abh_posts_tab abh_tab"><div class="abh_image"><a href="http://www.creators.com/read/lk" class="url" target="_blank" title="Mike Luckovich" rel="nofollow"><img data-del="avatar" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAMgAAADIAQAAAACFI5MzAAAAAnRSTlMAAHaTzTgAAAAcSURBVFjD7cGBAAAAAMOg+VNf4QBVAQAAAAB8BhRQAAEAnyMVAAAAAElFTkSuQmCC" class="avatar pp-user-avatar avatar-250 photo  lazyload" height='250' width='250' data-src="https://www.humortimes.com/wp-content/uploads/2021/01/mike-luckovich_thumb.jpg" decoding="async" /><noscript><img data-del="avatar" src='https://www.humortimes.com/wp-content/uploads/2021/01/mike-luckovich_thumb.jpg' class='avatar pp-user-avatar avatar-250 photo ' height='250' width='250' data-eio="l" /></noscript></a></div><div class="abh_social"> </div><div class="abh_text"><div class="abh_name">Latest posts by Mike Luckovich <span class="abh_allposts">(<a href="https://www.humortimes.com/author/mikeluckovich/">see all</a>)</span></div><div class="abh_description note"><ul> <li> <a href="https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/">Mike Luckovich for Jun 10, 2022</a><span> - June 10, 2022</span> </li> <li> <a href="https://www.humortimes.com/100658/327387-mike-luckovich-for-jun-09-2022/">Mike Luckovich for Jun 09, 2022</a><span> - June 9, 2022</span> </li> <li> <a href="https://www.humortimes.com/100644/327306-mike-luckovich-for-jun-08-2022/">Mike Luckovich for Jun 08, 2022</a><span> - June 8, 2022</span> </li></ul></div></div> </section></div> </div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.humortimes.com/100669/327439-mike-luckovich-for-jun-10-2022/" data-a2a-title="Mike Luckovich for Jun 10, 2022"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACAAAAAgAQAAAABbAUdZAAAAAnRSTlMAAHaTzTgAAAAMSURBVAjXY2AY3AAAAKAAAWElfUcAAAAASUVORK5CYII=" alt="Share" data-src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" alt="Share" data-eio="l"></noscript></a></div></div> </div>
<div id="below-content-sidebar" class="content-sidebar1">
<div id="custom_html-7" class="widget_text content-sidebar"><h2 class="content-sidebar-title">While we have you&#8230;</h2><div class="textwidget custom-html-widget"><p>… we have a small favor to ask. More and more people are reading the <strong><em>Humor Times</em></strong>, but advertising revenues for internet sites everywhere keep falling. And unlike so many other websites, we have not put up a paywall -- we want to keep this much-loved (and much-needed!) <strong>political humor</strong> free, if possible!</p>
<p>So you can see why we need to ask for your help. The <em>Humor Times'</em> unique content takes a lot of time and effort to produce... but we do it because we believe uncompromising political satire is more important than ever these days.</p>
<p>If everyone who reads and likes our website helps fund it, <strong>we can continue to help people laugh at the news, rather than cry about it!</strong> For as little as $1, you can support the <em>Humor Times</em> – and it only takes a minute. Thank you!</p>
<form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
<input type="hidden" name="cmd" value="_s-xclick">
<input type="hidden" name="hosted_button_id" value="VBPNTNJQJ7ZBW">
<table>
<tr><td><select name="os0">
<option value="Every little bit helps">Every little bit helps $1</option>
<option value="Giving feels good">Giving feels good $5</option>
<option value="Feeling generous">Feeling generous $10</option>
<option value="Big helper">Big helper $25</option>
<option value="Keep the lights on">Keep the lights on $100</option>
<option value="Help with rent">Help with rent $500</option>
<option value="Our friend for life!">Our friend for life! $1,000</option>
</select> </td></tr>
<tr><td>
<input type="hidden" name="currency_code" value="USD">
<input type="image" style="vertical-align: middle; padding-right: 15px;" align="left" src="https://www.humortimes.com/wp-content/uploads/images1/Donate-Button-orig.png" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
<img alt="" border="0" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" width="1" height="1" data-src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" decoding="async" class="lazyload"><noscript><img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1" data-eio="l"></noscript>
<p style="font-size: 12px; font-style: italic; vertical-align: middle;">(Note: While this link will take you to a PayPal page, you have the option of using your credit card without joining PayPal. All amounts in USD.)</p>
</td></tr>
</table>
</form>
<p>Or, please consider becoming a <strong>Sustaining Supporter</strong> via our <a href="https://www.patreon.com/humortimes" target="_blank" rel="noopener"><strong>Patreon Page</strong></a>, contributing a certain amount each month. You can do it for as long or as short a time as you like. It's a huge help with our monthly budget!</p>
<p>And/or, <a href="https://subs.humortimes.com">subscribe to the monthly <strong><em>Humor Times</em></strong> magazine</a>! Subscriptions make great gifts!</p></div></div> </div>
<footer class="entry-meta" aria-label="Entry meta">
<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.humortimes.com/topics/cartoons/creators/" rel="category tag">Creators</a>, <a href="https://www.humortimes.com/topics/cartoons/creators/luckovich/" rel="category tag">Luckovich</a></span> <span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://www.humortimes.com/tag/cartoonists/" rel="tag">cartoonists</a>, <a href="https://www.humortimes.com/tag/cartoons/" rel="tag">cartoons</a>, <a href="https://www.humortimes.com/tag/editorial-cartoons/" rel="tag">editorial cartoons</a>, <a href="https://www.humortimes.com/tag/mike-luckovich/" rel="tag">Mike Luckovich</a>, <a href="https://www.humortimes.com/tag/news-2/" rel="tag">news</a>, <a href="https://www.humortimes.com/tag/political-cartoonists/" rel="tag">political cartoonists</a>, <a href="https://www.humortimes.com/tag/political-cartoons/" rel="tag">political cartoons</a>, <a href="https://www.humortimes.com/tag/political-satire/" rel="tag">political satire</a>, <a href="https://www.humortimes.com/tag/satire/" rel="tag">satire</a></span> <nav id="nav-below" class="post-navigation" aria-label="Single Post">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.humortimes.com/100659/327267-john-deering-for-jun-09-2022/" rel="prev">John Deering for Jun 09, 2022</a></span></div> </nav>
</footer>
</div>
</article>
<div class="comments-area">
<div id="disqus_thread"></div>
</div>
</main>
</div>
<div class="widget-area sidebar is-right-sidebar grid-25 tablet-grid-25 grid-parent" id="right-sidebar">
<div class="inside-right-sidebar">
<aside id="a2a_share_save_widget-5" class="widget inner-padding widget_a2a_share_save_widget"><h2 class="widget-title">Share the Humor Times!</h2><div class="a2a_kit a2a_kit_size_32 addtoany_list"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACAAAAAgAQAAAABbAUdZAAAAAnRSTlMAAHaTzTgAAAAMSURBVAjXY2AY3AAAAKAAAWElfUcAAAAASUVORK5CYII=" alt="Share" data-src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" alt="Share" data-eio="l"></noscript></a></div></aside><aside id="custom_html-13" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Follow Us / RSS Feed</h2><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.facebook.com/HumorTimes" rel="noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAF4AAABkAQAAAAAnSLoIAAAAAnRSTlMAAHaTzTgAAAATSURBVDjLY2AYBaNgFIyCUQADAAUUAAEhUFEtAAAAAElFTkSuQmCC" title="HT Facebook page" alt="social media icon" class="follow-icon lazyload" width="36" height="36" data-src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_fb.png" decoding="async"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_fb.png" title="HT Facebook page" alt="social media icon" class="follow-icon" width="36" height="36" data-eio="l"></noscript></a>
<a target="_blank" href="https://twitter.com/humortimes" rel="noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAF4AAABkAQAAAAAnSLoIAAAAAnRSTlMAAHaTzTgAAAATSURBVDjLY2AYBaNgFIyCUQADAAUUAAEhUFEtAAAAAElFTkSuQmCC" title="HT Twitter" alt="social media icon" class="follow-icon lazyload" width="36" height="36" data-src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_twitter.png" decoding="async"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_twitter.png" title="HT Twitter" alt="social media icon" class="follow-icon" width="36" height="36" data-eio="l"></noscript></a>
<a target="_blank" href="https://www.youtube.com/user/TheHumorTimes" rel="noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAF4AAABkAQAAAAAnSLoIAAAAAnRSTlMAAHaTzTgAAAATSURBVDjLY2AYBaNgFIyCUQADAAUUAAEhUFEtAAAAAElFTkSuQmCC" title="HT YouTube page" alt="social media icon" class="follow-icon lazyload" width="36" height="36" data-src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_youtube.png" decoding="async"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_youtube.png" title="HT YouTube page" alt="social media icon" class="follow-icon" width="36" height="36" data-eio="l"></noscript></a>
<a target="_blank" href="https://www.pinterest.com/humortimes" rel="noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAF4AAABkAQAAAAAnSLoIAAAAAnRSTlMAAHaTzTgAAAATSURBVDjLY2AYBaNgFIyCUQADAAUUAAEhUFEtAAAAAElFTkSuQmCC" title="HT Pinterest page" alt="social media icon" class="follow-icon lazyload" width="36" height="36" data-src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_pinterest.png" decoding="async"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_pinterest.png" title="HT Pinterest page" alt="social media icon" class="follow-icon" width="36" height="36" data-eio="l"></noscript></a>
<a target="_blank" href="https://www.humortimes.com/newsletter/" rel="noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQAAAABYmaj5AAAAAnRSTlMAAHaTzTgAAAAUSURBVDjLY2AYBaNgFIyCUUBPAAAFeAABKXG5/AAAAABJRU5ErkJggg==" title="HT Free Newsletter" alt="social media icon" class="follow-icon lazyload" width="36" height="36" data-src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_newsletter.png" decoding="async"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_newsletter.png" title="HT Free Newsletter" alt="social media icon" class="follow-icon" width="36" height="36" data-eio="l"></noscript></a>
<a target="_blank" href="https://follow.it/humortimes" rel="noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAF4AAABkAQAAAAAnSLoIAAAAAnRSTlMAAHaTzTgAAAATSURBVDjLY2AYBaNgFIyCUQADAAUUAAEhUFEtAAAAAElFTkSuQmCC" title="HT RSS Feed" alt="social media icon" class="follow-icon lazyload" width="36" height="36" data-src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_rss.png" decoding="async"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/icons-cute/cute_rss.png" title="HT RSS Feed" alt="social media icon" class="follow-icon" width="36" height="36" data-eio="l"></noscript></a></div></aside><aside id="custom_html-14" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Editorial Cartoons Daily!</h2><div class="textwidget custom-html-widget"><p style="font-size: 100%;">Check out new <a href="/editorial-cartoons-daily/">hilarious editorial cartoons</a> page, updated daily! Bookmark the page and share it!</p>
<a href="/editorial-cartoons-daily/"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAlgAAAG0AQAAAADGc2QVAAAAAnRSTlMAAHaTzTgAAAA3SURBVHja7cExAQAAAMKg9U9tCy+gAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAC+BoFwAAFeYRu1AAAAAElFTkSuQmCC" alt="Humor Times editorial cartoons" data-src="https://www.humortimes.com/wp-content/uploads/2021/03/297378_image.jpg" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/uploads/2021/03/297378_image.jpg" alt="Humor Times editorial cartoons" data-eio="l"></noscript></a></div></aside><aside id="adrotate_widgets-88" class="widget inner-padding adrotate_widgets"><div class="g g-14"><div class="g-col b-14 a-114"><a class="gofollow" data-track="MTE0LDE0LDEsNjA=" href="https://shrubexplains.pressbooks.com/" target="_blank" rel="nofollow"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAASwAAAJYAQAAAADwXeaSAAAAAnRSTlMAAHaTzTgAAAAuSURBVHja7cEBDQAAAMKg909tDjegAAAAAAAAAAAAAAAAAAAAAAAAAAAAAODPAFtoAAFIoNaHAAAAAElFTkSuQmCC" alt="George Shrub ad" data-src="https://www.humortimes.com/wp-content/banners/Lippman-banner-300x600.png" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/banners/Lippman-banner-300x600.png" alt="George Shrub ad" data-eio="l"></noscript></a></div></div></aside><aside id="custom_html-3" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Support the Cause of Political Humor!</h2><div class="textwidget custom-html-widget"><a href="https://www.patreon.com/humortimes"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAASwAAACWAQAAAABMIIh/AAAAAnRSTlMAAHaTzTgAAAAdSURBVFjD7cEBDQAAAMKg909tDjegAAAAAADgyQAW2gABp5XTtgAAAABJRU5ErkJggg==" alt="cartoon galleries" data-src="https://www.humortimes.com/wp-content/uploads/images1/push-banner-300w.jpg" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/push-banner-300w.jpg" alt="cartoon galleries" data-eio="l" /></noscript></a>
<p style="font-size:100%; margin-top:10px;">Become a <strong>Humor Times patron</strong> via <strong><a href="https://www.patreon.com/humortimes">Patreon.com</a></strong>! Help us keep the lights on with a small (or large!) sustaining monthly donation. Check out our current wonderful <strong><a href="/donate-cause-political-humor/thank-you-humor-times-patrons/">Sustaining Supporters here</a></strong>! Please join them, and help support independent media! We thank you.</p></div></aside><aside id="custom_html-12" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">NEW! Humor Times Tees!</h2><div class="textwidget custom-html-widget"><center><a href="https://subs.humortimes.com/subs-store.php"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAMgAAADtAQAAAADSQge2AAAAAnRSTlMAAHaTzTgAAAAcSURBVFjD7cEBDQAAAMKg909tDwcUAAAAAADwbxgSAAFyxGsDAAAAAElFTkSuQmCC" alt="Humor Times Tees" data-src="https://www.humortimes.com/wp-content/uploads/images1/HT-tshirt.jpg" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/HT-tshirt.jpg" alt="Humor Times Tees" data-eio="l" /></noscript></a></center>
<p style="font-size:100%; margin-top:10px;">Be the first on your block to get the new <strong><a href="https://subs.humortimes.com/subs-store.php">Humor Times t-shirt!</a></strong>!</p></div></aside><aside id="custom_html-11" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Letters to the Editor</h2><div class="textwidget custom-html-widget"><strong>Wanna be heard?</strong> Of course you do! Now you can share your wisdom with all our readers, on the new <strong><a href="/more/letters-to-editor/">Letters to the Editor</a></strong> page!</div></aside><aside id="adrotate_widgets-81" class="widget inner-padding adrotate_widgets"><div class="g g-3"><div class="g-col b-3 a-92"><a class="gofollow" data-track="OTIsMywxLDYw" href="http://www.capitalac.com/" target="_blank" rel="nofollow"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAASwAAAJYAQAAAADwXeaSAAAAAnRSTlMAAHaTzTgAAAAuSURBVHja7cEBDQAAAMKg909tDjegAAAAAAAAAAAAAAAAAAAAAAAAAAAAAODPAFtoAAFIoNaHAAAAAElFTkSuQmCC" alt="CAC banner ad" data-src="https://www.humortimes.com/wp-content/banners/CAC-banner-300x600.gif" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/banners/CAC-banner-300x600.gif" alt="CAC banner ad" data-eio="l"></noscript></a></div></div></aside><aside id="adrotate_widgets-80" class="widget inner-padding adrotate_widgets"></aside><aside id="wp_paypal_payment_widgets" class="widget inner-padding widget_wp_paypal_payment"><h2 class="widget-title">Like this content?</h2><div id="accept_paypal_payment_form"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" class="wp_accept_pp_button_form_classic"><input type="hidden" name="cmd" value="_xclick" /><input type="hidden" name="business" value="info@humortimes.com" /><input type="hidden" name="item_name" value="Donate to this Author or Artist!  " /><input type="hidden" name="currency_code" value="USD" /><div class="wpapp_payment_subject"><span class="payment_subject"><strong>Donate to this Author or Artist!  </strong></span></div><select id="amount" name="amount" class=""><option value="1">Toss it in the hat - $1</option><option value="5">Real nice - $5</option><option value="10">Cooler than most - $10</option><option value="20">Now we’re talkin’ - $20</option><option value="50">Oh yeah, baby! - $50</option><option value="100">WOOHOO!!! - $100</option></select><div class="wpapp_other_amount_label"><strong>Other Amount:</strong></div><div class="wpapp_other_amount_input"><input type="number" min="1" step="any" name="other_amount" title="Other Amount" value="" class="wpapp_other_amt_input" style="max-width:80px;" /></div><div class="wpapp_ref_title_label"><strong>Your Email Address:</strong></div><input type="hidden" name="on0" value="Reference" /><div class="wpapp_ref_value"><input type="text" name="os0" maxlength="60" value="" class="wp_pp_button_reference" /></div><input type="hidden" name="no_shipping" value="0" /><input type="hidden" name="no_note" value="1" /><input type="hidden" name="bn" value="TipsandTricks_SP" /><input type="hidden" name="return" value="https://www.humortimes.com/paypal-return" /><input type="hidden" name="cancel_return" value="https://www.humortimes.com" /><div class="wpapp_payment_button"><input type="image" src="https://www.humortimes.com/wp-content/plugins/wordpress-easy-paypal-payment-or-donation-accept-plugin/btn_donate_LG.gif" name="submit" alt="Make payments with payPal - it's fast, free and secure!" /></div></form></div>
<script type="text/javascript">
jQuery(document).ready(function($) {
    $(".wp_accept_pp_button_form_classic").submit(function(e){
        var form_obj = $(this);
        var other_amt = form_obj.find("input[name=other_amount]").val();
        if (!isNaN(other_amt) && other_amt.length > 0){
            options_val = other_amt;
            //insert the amount field in the form with the custom amount
            $("<input>").attr({
                type: "hidden",
                id: "amount",
                name: "amount",
                value: options_val
            }).appendTo(form_obj);
        }
        return;
    });
});
</script></aside><aside id="custom_html-4" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Fun Stuff!</h2><div class="textwidget custom-html-widget"><a href="/2833/cartoon-caption-contest/"><strong>Enter our Caption Contest!</strong><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAP8AAAEBAQAAAACfnE66AAAAAnRSTlMAAHaTzTgAAAAfSURBVGje7cEBDQAAAMKg909tDwcUAAAAAAAAAMC5ASEhAAEsnEjrAAAAAElFTkSuQmCC" alt="cartoon caption contest" data-src="https://www.humortimes.com/wp-content/uploads/caption-contest/fill_in_blank-sm.jpg" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/uploads/caption-contest/fill_in_blank-sm.jpg" alt="cartoon caption contest" data-eio="l" /></noscript></a>
</div></aside><aside id="custom_html-9" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4584792120415811" data-ad-slot="9833610188" data-ad-format="link" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside> </div>
</div>
</div>
</div>
<a title="Scroll back to top" aria-label="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
</a>
<div class="site-footer">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container grid-parent">
<div class="inside-footer-widgets">
<div class="footer-widget-1 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
<aside id="adrotate_widgets-86" class="widget inner-padding adrotate_widgets"><div class="g g-12"><div class="g-col b-12 a-57"><a class="gofollow" data-track="NTcsMTIsMSw2MA==" href="https://www.itex.com/referral/" target="_blank" rel="nofollow"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAOwAAADsAQAAAABfqHe5AAAAAnRSTlMAAHaTzTgAAAAeSURBVFjD7cExAQAAAMKg9U9tCj+gAAAAAAAAAH4GHJQAASEnfLgAAAAASUVORK5CYII=" width="236" height="236" alt="ITEX ad" data-src="https://www.humortimes.com/wp-content/banners/ITEX-SavetheDay-236w.jpg" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/banners/ITEX-SavetheDay-236w.jpg" width="236" height="236" alt="ITEX ad" data-eio="l" /></noscript></a></div></div></aside> </div>
<div class="footer-widget-2 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
<aside id="custom_html-6" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">HT among the Best!</h2><div class="textwidget custom-html-widget"><a href="/60568/humor-times-top-political-cartoon-website/"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAJgAAACYAQAAAAAwuR2MAAAAAnRSTlMAAHaTzTgAAAAZSURBVEjH7cEBDQAAAMKg909tDwcUAADwYgvgAAHe71uwAAAAAElFTkSuQmCC" alt="Humor Times Top Humor Blog" data-src="https://www.humortimes.com/wp-content/uploads/images1/expertido.org-seal-best-blogger-humor.jpg" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/expertido.org-seal-best-blogger-humor.jpg" alt="Humor Times Top Humor Blog" data-eio="l" /></noscript></a></div></aside> </div>
<div class="footer-widget-3 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
<aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Top Website!</h2><div class="textwidget custom-html-widget"><a href="https://www.thegoodestate.com/" target="_blank" rel="nofollow noopener"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAPoAAACxAQAAAADFCJ0/AAAAAnRSTlMAAHaTzTgAAAAdSURBVFjD7cEBDQAAAMKg909tDjegAAAAAADgwAAW0QABjM9tnwAAAABJRU5ErkJggg==" alt="Humor Times awarded" data-src="https://www.humortimes.com/wp-content/uploads/images1/topsite-250.png" decoding="async" class="lazyload" /><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/topsite-250.png" alt="Humor Times awarded" data-eio="l" /></noscript></a></div></aside> </div>
<div class="footer-widget-4 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
<aside id="a2a_share_save_widget-6" class="widget inner-padding widget_a2a_share_save_widget"><h2 class="widget-title">Share the Humor Times!</h2><div class="a2a_kit a2a_kit_size_32 addtoany_list"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACAAAAAgAQAAAABbAUdZAAAAAnRSTlMAAHaTzTgAAAAMSURBVAjXY2AY3AAAAKAAAWElfUcAAAAASUVORK5CYII=" alt="Share" data-src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" alt="Share" data-eio="l"></noscript></a></div></aside> </div>
</div>
</div>
</div>
<footer class="site-info" aria-label="Site" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container grid-parent">
<div class="copyright-bar">
All content <span class="copyright">&copy; 2007-2022 </span> <a href="https://www.humortimes.com" target="_blank" itemprop="url">Humor Times</a> &bull; Theme <span class="copyright">&copy; 2022 </span> <a href="https://generatepress.com" target="_blank" itemprop="url">GeneratePress</a> &bull; Website created & maintained by <a href="https://www.facebook.com/WebsiteCreationMaintenance/" target="_blank" itemprop="url">WCM</a> </div>
</div>
</footer>
</div>
<a title="Scroll back to top" aria-label="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
</a><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:10px;right:90px;background-color:#ffffff"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.humortimes.com%2F100669%2F327439-mike-luckovich-for-jun-10-2022%2F&amp;linkname=Mike%20Luckovich%20for%20Jun%2010%2C%202022%20-%20Mike%20Luckovich%2C%20Humor%20Times" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACAAAAAgAQAAAABbAUdZAAAAAnRSTlMAAHaTzTgAAAAMSURBVAjXY2AY3AAAAKAAAWElfUcAAAAASUVORK5CYII=" alt="Share" data-src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" decoding="async" class="lazyload"><noscript><img src="https://www.humortimes.com/wp-content/uploads/images1/ShareButton-32.png" alt="Share" data-eio="l"></noscript></a></div><div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div> <script async type="text/javascript">
	  (adsbygoogle = window.adsbygoogle || []).push({
		google_ad_client: "ca-pub-4584792120415811",
		enable_page_level_ads: true
	  });
	</script>
<script id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><link rel='stylesheet' id='modal-css' href='https://www.humortimes.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.25' media='all' />
<script id='eio-lazy-load-js-before'>
var eio_lazy_vars = {"exactdn_domain":"","skip_autoscale":0,"threshold":0};
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/ewww-image-optimizer/includes/lazysizes.min.js?ver=652' id='eio-lazy-load-js'></script>
<script id='jshowoff-adrotate-js-extra'>
var impression_object = {"ajax_url":"https:\/\/www.humortimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script id='clicktrack-adrotate-js-extra'>
var click_object = {"ajax_url":"https:\/\/www.humortimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script id='disqus_embed-js-extra'>
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"100669 https:\/\/www.humortimes.com\/?p=100669","disqusShortname":"humortimes","disqusTitle":"Mike Luckovich for Jun 10, 2022","disqusUrl":"https:\/\/www.humortimes.com\/100669\/327439-mike-luckovich-for-jun-10-2022\/","postId":"100669"};
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/responsive-lightbox/assets/swipebox/jquery.swipebox.min.js?ver=2.3.5' id='responsive-lightbox-swipebox-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script id='responsive-lightbox-js-extra'>
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"ajaxComplete","activeGalleries":"1","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"3000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"1","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.humortimes.com\/wp-admin\/admin-ajax.php","nonce":"6945530a8c","preview":"false","postId":"100669"};
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.3.5' id='responsive-lightbox-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.13.1' id='jquery-ui-mouse-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.13.1' id='jquery-ui-slider-js'></script>
<script id='ppress-frontend-script-js-extra'>
var pp_ajax_form = {"ajaxurl":"https:\/\/www.humortimes.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"d897792842","disable_ajax_form":"false"};
</script>
<script defer src='https://www.humortimes.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.13' id='ppress-frontend-script-js'></script>
<!--[if lte IE 11]>
<script defer src='https://www.humortimes.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script defer src='https://www.humortimes.com/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js'></script>
<script id='generate-navigation-search-js-extra'>
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script defer src='https://www.humortimes.com/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=3.1.3' id='generate-navigation-search-js'></script>
<script id='generate-back-to-top-js-extra'>
var generatepressBackToTop = {"smooth":"1"};
</script>
<script defer src='https://www.humortimes.com/wp-content/themes/generatepress/assets/js/back-to-top.min.js?ver=3.1.3' id='generate-back-to-top-js'></script>
<script defer src='https://www.humortimes.com/wp-includes/js/comment-reply.min.js?ver=6.0' id='comment-reply-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/newsletter-leads/libs/simplemodal/jquery.simplemodal.js?ver=1.2.8' id='simplemodal-js'></script>
<script defer src='https://www.humortimes.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.25' id='modal-js'></script>
<script defer src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=6.0' async='async' id='remote_sdk-js'></script>
<div id="tnp-leads-topbar">
<div class="tnp tnp-subscription-minimal"><form action="https://www.humortimes.com/?na=s" method="post"><input type="hidden" name="nr" value="leads-bar"><input type="hidden" name="nlang" value="">
<input class="tnp-email" type="email" required name="ne" value="" placeholder="Subscribe"><input class="tnp-submit" type="submit" value="FREE &quot;Cartoon of the Week&quot; Newsletter!"></form></div>
<label id="tnp-leads-topbar-close" onclick="tnp_leads_close_topbar()"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="24px" height="24px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><circle fill="#fff" stroke="#fff" stroke-width="1" stroke-linecap="square" stroke-miterlimit="10" cx="12" cy="12" r="11" stroke-linejoin="miter" /><line data-color="color-2" fill="#fff" stroke="#343434" stroke-width="1" stroke-linecap="square" stroke-miterlimit="10" x1="16" y1="8" x2="8" y2="16" stroke-linejoin="miter" /><line data-color="color-2" fill="none" stroke="#343434" stroke-width="1" stroke-linecap="square" stroke-miterlimit="10" x1="16" y1="16" x2="8" y2="8" stroke-linejoin="miter" /></g></svg></label>
</div>
<script>
                var tnp_leads_restart = 5184000000;
                var tnp_leads_test = false;
                function tnp_leads_close_topbar() {
                    window.localStorage.setItem('tnp-leads-topbar', '' + (new Date().getTime()));
                    document.getElementById('tnp-leads-topbar').className = '';
                }
                document.addEventListener("DOMContentLoaded", function () {
                    let time = window.localStorage.getItem('tnp-leads-topbar');
                    if (!tnp_leads_test && time !== null && (new Date().getTime()) < parseInt(time) + tnp_leads_restart) {
                        document.getElementById('tnp-leads-topbar').style.display = 'none';
                    } else {
                        document.getElementById('tnp-leads-topbar').className = 'tnp-leads-topbar-show';
                    }
                });
            </script>

<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-7').gslider({ groupid: 7, speed: 8000 });
	jQuery('.g-10').gslider({ groupid: 10, speed: 9000 });
	jQuery('.g-13').gslider({ groupid: 13, speed: 12000 });
}
});
</script>

</body>
</html>
